Back to overview
Maintenance
Upgrading Infrastructure
May 1, 2026 at 12:39pm UTC
–
May 1, 2026 at 12:39pm UTC
Affected services
Web App
Desktop Apps
API
Resolved
May 1, 2026 at 12:39pm UTC
Maintenance ended
Affected services
Created
May 1, 2026 at 12:39pm UTC
We are currently upgrading our infrastructure to support a higher user base.
Affected services